1 opam-version: "2.0"
2 synopsis: "Official release 4.10.0"
3 maintainer: "platform@lists.ocaml.org"
4 authors: "Xavier Leroy and many contributors"
5 homepage: "https://ocaml.org"
6 bug-reports: "https://github.com/ocaml/opam-repository/issues"
7 depends: [
8 "ocaml" {= "4.10.0" & post}
9 "base-unix" {post}
10 "base-bigarray" {post}
11 "base-threads" {post}
12 ]
13 conflict-class: "ocaml-core-compiler"
14 available: !(os = "macos" & arch = "arm64")
15 flags: compiler
16 setenv: CAML_LD_LIBRARY_PATH = "%{lib}%/stublibs"
17 build: [
18 [
19 "./configure"
20 "--prefix=%{prefix}%"
21 "-C"
22 "CC=cc" {os = "openbsd" | os = "freebsd" | os = "macos"}
23 "ASPP=cc -c" {os = "openbsd" | os = "freebsd" | os = "macos"}
24 ]
25 [make "-j%{jobs}%" "world"]
26 [make "-j%{jobs}%" "world.opt"]
27 ]
28 install: [make "install"]
29 post-messages: [
30 """\
31 A failure in the middle of the build may be caused by build parallelism
32 (enabled by default).
33 Please file a bug report at https://github.com/ocaml/opam-repository/issues"""
34 {failure & jobs > "1"}
35 """\
36 You can try installing again including --jobs=1
37 to force a sequential build instead."""
38 {failure & jobs > "1" & opam-version >= "2.0.5"}
39 ]
40 dev-repo: "git://github.com/ocaml/ocaml"
41 extra-files: [
42 "ocaml-base-compiler.install" "md5=3e969b841df1f51ca448e6e6295cb451"
43 ]
44 url {
45 src: "https://github.com/ocaml/ocaml/archive/4.10.0.tar.gz"
46 checksum:
47 "sha256=58bae0f0a79daf86ec755a173e593fef4ef588f15c6185993af88ceb9722bc39"
48 }
49